[AMRadio] The Viking II is FINALLY starting to work


doxemf at aol.com doxemf at aol.com
Sun Feb 3 13:04:43 EST 2008


Ellen,

 It sounds like you are almost there !
   I just got my VKII putting out power after replacing a broken and 
worn out roller inductor.
One thing that no one has mentioned is that the plate meter shunts, 
both final and mod, that are located on a terminal strip near the 
center rear under the chassis, can be poorly soldered if the rig was 
kit built. They are only about 1/2 inch lengths of nichrome wire shaped 
as little covered loops. Nichrome wire is not solderable so they must 
have been treated originally for the solder to take. In anothe VKII I 
have that was kit the solder connection had become unbonded and under 
load was intermittent giving all kinds of current readings and behavior 
including readings without the plate switch on. Just to let you know.
   Another common problem is that the smaller silver mica loading caps 
can short out and the loading controls will not behave properly. I 
think that is a problem I am having now myself but haven't pulled the 
front panel again to check them. They are under rated and known to 
become leaky.
   Check out the condition of the roller bar also as mine had been worn 
oval with erratic connection when trying to tune. The roller itself was 
ok.

Enjoy !
Bill, KB3DKS



________________________________________________________________________
More new features than ever.  Check out the new AOL Mail ! - 
http://webmail.aol.com


More information about the AMRadio mailing list

This page last updated 24 Oct 2017.