[AMRadio] push pull output XFMRs and neg feedback


John Coleman jc at pctechref.com
Thu May 21 10:17:31 EDT 2009


Jim:
        Open Loop:
        A square wave input at about 1000 HZ results in a square wave at the grids of the KT88s.  Both channels appear equal in amplitude at the grids of the KT88s.  But the output of the 8 ohms tap to the speakers is not a square wave but is sort of a pointed sine wave. And the good channel has a nearly twice the peak to peak voltage.

        As inverse feedback is added:
        As the inverse feedback is added, the good channel begins to flatten out into a square wave and looks pretty good with only a small amount of ring at the leading edge.  However, When inverse feedback is added to the channel of question, the wave begins to flatten but goes into sustained ring at the top and bottom of the square wave.  Adding just a little more FB and it breaks into oscillation.

        The one thing I haven't checked is switching the speakers.  There may be some weird thing with the crossover networks making a resonate circuit there.  It's easier than changing out the output XFMRs.  I could try changing the KT88s as well.  Now that would be weird!!  Dennis said he thought it could be a shorted turn in the output XFMR, in spite of NOS, and it is beginning to look more and more true.

I seem to always find the weird stuff.
I serviced TVs for many years before going into the computer field.  I have met and talked with many TV techs and not one of them has ever detected or changed out the main power supply choke in the old tube type sets.  Yet I have found two in my life that were shorted.  No inductance:  Ripple was the same on both ends.  So either the others guys just never fixed the ripple in the picture or they never saw it.

John Coleman, WA5BXO



More information about the AMRadio mailing list

This page last updated 23 Oct 2017.