[AMRadio] Viking Valiant frequency knob play


Jay Bromley jayw5jay at cox.net
Tue Aug 16 01:15:42 EDT 2016


Sounds like you broke the bakelite flex coupling that drives the cap.  Pain
in the backside to fix, you have to take off the knobs and front panel.
Some guys repair the broken bakelite with circuit board material or find a
good junkbox that has a coupling that will work.  I don't remember the
issue, but I think in Electric Radio had an article on how to repair the
coupling.

73 de w5jay..  


>>>>Hi all,


Any thoughts on fixing the play in my valiant VFO control.  It seems to be
mechanical.  I can move the dial a little and there is no motion in the
tuning cap.  I can't really see without dismantling the VFO shield what is
going on.  It seems like the linkage is loose but the set screws are tight
on the shaft.  Is there a coupling spider in there that is loose?  Or am I
asking too much for a 60  year old rig and maybe I should put it back
together and just enjoy using it.


Thanks,


Steve KC5WN



______________________________________________________________
Our Main Website: http://www.amfone.net
AMRadio mailing list
Archives: http://mailman.qth.net/pipermail/amradio/
List Rules (must read!): http://w5ami.net/amradiofaq.html List Home:
http://mailman.qth.net/mailman/listinfo/amradio
Post: AMRadio at mailman.qth.net
To unsubscribe, send an email to amradio-request at mailman.qth.net with the
word unsubscribe in the message body.

This list hosted by: http://www.qsl.net
Please help support this email list: http://www.qsl.net/donate.html Message
delivered to jayw5jay at cox.net



More information about the AMRadio mailing list

This page last updated 20 Nov 2017.